php5.4の動作状況について


php5.4対応状況

現状、a-blog cmsの対応phpのバージョンですが、5.1.6〜5.3.xになっており php5.4には対応しておりません。 対応していない原因ですが、ioncube loader がphp5.4だとうまく動かない箇所があり 様子を見ている状態でした。

最近になり、ioncube loaderのバージョンもあがり検証が出来る環境になりましたので 検証結果をここでしたいと思います。

検証環境

レンタルサーバさくらインターネット
サービス名さくらのレンタルサーバ スタンダード
OSFreeBSD 7.1
php5.4.17
mysql5.5

検証結果

上記のサーバでa-blog cmsを動かした所、全機能を一通りチェックをしましたが、 正常に動いています。

今後の対応

今回の検証でphp5.4でa-blog cmsが動きましたが、まだ検証情報が少ない為、 公式での正式対応の発表はもう少し先になります。

しかし、php5.4でしか動かないサーバもあるかと思いますので、正式に対応を発表するまでの間php5.4で動かして、万が一不具合がある場合は無償で対応させて頂きたいと思います。

同じタグ付けがされている記事