php5.6 - php7.0 の環境の場合、Ver. 2.11.15, Ver. 2.11.16 で重大な問題がみつかりました。

php5.6 - php7.0 の環境で Ver. 2.11.15 または Ver. 2.11.16 を利用している場合、いくつかの機能が動作しない重大な問題がみつかりました。

問題の内容

Ver. 2.11.15 で php7.4 に対応したことにより、a-blog cms で利用してるライブラリもアップデートされたのですが、 一部ライブラリでphp5.6 - php7.0 で動作しなくなるものが含まれておりました。

現在わかってる段階で以下機能が動作しません。

  • メディアのアップロード
  • フォーム
  • チェックリスト

対象

a-blog cms Ver. 2.11.15 または Ver. 2.11.16 を利用していて、phpのバージョンが php5.6 - php7.0 の場合

対応策

a-blog cms Ver. 2.11.15 または Ver. 2.11.16 をお使いで、php5.6 - php7.0 をお使いの場合は、お手数ですが以下対策2つのうち、どちらかの対応をお願いいたします。

  • a-blog cms Ver. 2.11.17にアップデート
  • サーバーのphpのバージョンをphp7.1 - php7.4 にアップデートし、 ionCube Loaderと a-blog cms の パッケージを php7.1 - php7.4 のものに置き換え

この度はご迷惑をお掛けしてしまい申し訳ございません。 今後ともa-blog cmsをよろしくお願いいたします。

同じタグ付けがされている記事